aboutsummaryrefslogtreecommitdiffstats
path: root/INSTALL
Commit message (Expand)AuthorAgeFilesLines
* tst: Extend cross-test-ssh.sh to specify if target date can be alteredLukasz Majewski2021-03-081-0/+15
* Update INSTALL with package versions that are known to workTulio Magno Quites Machado Filho2021-01-251-13/+13
* config: Allow memory tagging to be enabled when configuring glibcRichard Earnshaw2020-12-211-0/+14
* s390x: Require GCC 7.1 or later to build glibc.Stefan Liebler2020-12-171-0/+3
* Linux: Require properly configured /dev/pts for PTYsFlorian Weimer2020-10-071-8/+3
* Regenerate INSTALL for ARC port updates.Carlos O'Donell2020-07-221-0/+5
* Remove --enable-obsolete-nsl configure flagPetr Vorel2020-07-081-9/+0
* x86: Add --enable-cet=permissiveH.J. Lu2020-05-181-11/+15
* powerpc64le: blacklist broken GCC compilers (e.g GCC 7.5.0)Paul E. Murphy2020-04-301-3/+5
* powerpc64le: bump binutils version requirement to >= 2.26Paul E. Murphy2020-04-301-0/+4
* powerpc64le: raise GCC requirement to 7.4 for long double transitionPaul E. Murphy2020-04-301-0/+6
* Update newest tested versions of dependencies in install.texiSiddhesh Poyarekar2020-02-011-5/+5
* Prefer https to http for gnu.org and fsf.org URLsPaul Eggert2019-09-071-1/+1
* Update install and NEWS for 2.30 release.Carlos O'Donell2019-08-011-5/+5
* Extend BIND_NOW to installed programs with --enable-bind-nowFlorian Weimer2019-04-251-4/+4
* Require GCC 6.2 or later to build glibc.Joseph Myers2019-02-011-7/+2
* Prepare for 2.29 releaseSiddhesh Poyarekar2019-01-311-7/+7
* Require GCC 5 or later to build glibc (bug 23993).Joseph Myers2018-12-211-2/+2
* locale: Rewrite locale/gen-translit.pl in PythonFlorian Weimer2018-12-181-4/+3
* Patch to require Python 3.4 or later to build glibc.Joseph Myers2018-10-291-4/+4
* Use gen-libm-test.py to generate ulps table for manual.Joseph Myers2018-10-241-2/+3
* Don't build libnsl for new ABIsAndreas Schwab2018-09-241-1/+4
* Add --with-nonshared-cflags option to configureFlorian Weimer2018-08-171-0/+16
* Update install.texi documentation of uses of Perl and Python.Joseph Myers2018-08-131-36/+32
* Add convenience target 'install-locale-files'.Carlos O'Donell2018-08-021-6/+26
* Update tooling versions verified to work with glibc.Carlos O'Donell2018-07-311-10/+23
* INSTALL: Add a note for Intel CET statusH.J. Lu2018-07-191-0/+5
* Intel CET: Document --enable-cetH.J. Lu2018-07-181-0/+11
* testrun.sh: Implement --tool=strace, --tool=valgrindFlorian Weimer2018-07-041-7/+1
* New configure option --disable-crypt.Zack Weinberg2018-06-291-0/+11
* Document use of CC and CFLAGS in more detail (bug 20980, bug 21234).Joseph Myers2018-02-151-5/+14
* Fix typo in the previous commitDmitry V. Levin2018-01-311-1/+1
* Update information about the newest versions of tools used to build glibcDmitry V. Levin2018-01-311-6/+7
* Document that --enable-static-pie implies PIEH.J. Lu2017-12-191-1/+3
* Add --enable-static-pie configure option to build static PIE [BZ #19574]H.J. Lu2017-12-151-0/+9
* Remove --with-fp / --without-fp.Joseph Myers2017-12-121-4/+0
* Add elision tunablesRogerio Alves2017-12-051-3/+0
* plural.c: improve reproducibilityJuro Bystricky2017-11-301-5/+5
* Fix botched up regeneration in the last commitSiddhesh Poyarekar2017-11-161-2/+3
* Prefer https for Sourceware linksSiddhesh Poyarekar2017-11-161-2/+2
* Remove add-ons mechanism.Joseph Myers2017-10-051-17/+0
* Update contributors and latest gcc and binutils versionsSiddhesh Poyarekar2017-08-021-2/+2
* Add per-thread cache to mallocDJ Delorie2017-07-061-0/+6
* Require binutils 2.25 or later to build glibc.Joseph Myers2017-06-281-1/+1
* powerpc64le: Check for compiler features for float128Gabriel F. T. Gomes2017-06-261-0/+5
* Require GCC 4.9 or later for building glibc.Joseph Myers2017-06-191-2/+2
* Enable tunables by defaultSiddhesh Poyarekar2017-06-151-10/+8
* Assume that accept4 is always available and worksFlorian Weimer2017-04-191-7/+9
* Regenerate INSTALL.Joseph Myers2017-03-211-0/+6
* Document and fix --enable-bind-now [BZ #21015]Florian Weimer2017-03-021-0/+6