aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKarolin Seeger <kseeger@samba.org>2018-03-12 10:10:07 +0100
committerKarolin Seeger <kseeger@samba.org>2018-03-12 10:10:07 +0100
commit7d6f3297eb5695b32074e05d904e5bc2927d8324 (patch)
tree735fb750e5de252c89adb12febc655b0f1fbb931
parent8300e8e8c5f94fd1873cd856bdd83f89cb771de1 (diff)
downloadsamba-7d6f3297eb5695b32074e05d904e5bc2927d8324.tar.gz
samba-7d6f3297eb5695b32074e05d904e5bc2927d8324.tar.xz
samba-7d6f3297eb5695b32074e05d904e5bc2927d8324.zip
WHATSNEW: Add release notes for Samba 4.6.14.
Signed-off-by: Karolin Seeger <kseeger@samba.org>
-rw-r--r--WHATSNEW.txt80
1 files changed, 78 insertions, 2 deletions
diff --git a/WHATSNEW.txt b/WHATSNEW.txt
index 992007d3f75..ca1e471d4c8 100644
--- a/WHATSNEW.txt
+++ b/WHATSNEW.txt
@@ -1,4 +1,80 @@
==============================
+ Release Notes for Samba 4.6.14
+ March 13, 2018
+ =============================
+
+
+This is a security release in order to address the following defects:
+
+o CVE-2018-1050 (Denial of Service Attack on external print server.)
+o CVE-2018-1057 (Authenticated users can change other users' password.)
+
+
+=======
+Details
+=======
+
+o CVE-2018-1050:
+ All versions of Samba from 4.0.0 onwards are vulnerable to a denial of
+ service attack when the RPC spoolss service is configured to be run as
+ an external daemon. Missing input sanitization checks on some of the
+ input parameters to spoolss RPC calls could cause the print spooler
+ service to crash.
+
+ There is no known vulnerability associated with this error, merely a
+ denial of service. If the RPC spoolss service is left by default as an
+ internal service, all a client can do is crash its own authenticated
+ connection.
+
+o CVE-2018-1057:
+ On a Samba 4 AD DC the LDAP server in all versions of Samba from
+ 4.0.0 onwards incorrectly validates permissions to modify passwords
+ over LDAP allowing authenticated users to change any other users'
+ passwords, including administrative users.
+
+ Possible workarounds are described at a dedicated page in the Samba wiki:
+ https://wiki.samba.org/index.php/CVE-2018-1057
+
+
+Changes since 4.6.12:
+---------------------
+
+o Jeremy Allison <jra@samba.org>
+ * BUG 11343: CVE-2018-1050: Codenomicon crashes in spoolss server code.
+
+o Ralph Boehme <slow@samba.org>
+ * BUG 13272: CVE-2018-1057: Unprivileged user can change any user (and admin)
+ password.
+
+o Stefan Metzmacher <metze@samba.org>
+ * BUG 13272: CVE-2018-1057: Unprivileged user can change any user (and admin)
+ password.
+
+
+#######################################
+Reporting bugs & Development Discussion
+#######################################
+
+Please discuss this release on the samba-technical mailing list or by
+joining the #samba-technical IRC channel on irc.freenode.net.
+
+If you do report problems then please try to send high quality
+feedback. If you don't provide vital information to help us track down
+the problem then you will probably be ignored. All bug reports should
+be filed under the "Samba 4.1 and newer" product in the project's Bugzilla
+database (https://bugzilla.samba.org/).
+
+
+======================================================================
+== Our Code, Our Bugs, Our Responsibility.
+== The Samba Team
+======================================================================
+
+
+Release notes for older releases follow:
+----------------------------------------
+
+ ==============================
Release Notes for Samba 4.6.13
February 14, 2017
=============================
@@ -65,8 +141,8 @@ database (https://bugzilla.samba.org/).
======================================================================
-Release notes for older releases follow:
-----------------------------------------
+----------------------------------------------------------------------
+
==============================
Release Notes for Samba 4.6.12